Beiträge von riedlit

    Hi Leute -


    ich habe wieder mal massig log-ausgaben:

    Zitat

    [Tue Jan 10 18:37:57 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://www.tus-mureck.at/fotos…40-img5981?tmpl=component [Tue Jan 10 18:37:58 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://www.tus-mureck.at/fotos…41-img5991?tmpl=component [Tue Jan 10 18:37:58 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://www.tus-mureck.at/fotos…41-img5991?tmpl=component [Tue Jan 10 18:38:01 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://www.tus-mureck.at/fotos…42-img6010?tmpl=component [Tue Jan 10 18:38:02 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://www.tus-mureck.at/fotos…42-img6010?tmpl=component [Tue Jan 10 18:38:02 2012] [error] [client 46.206.115.253] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://tus-mureck.at/fotos/63-…93-img3467?tmpl=component [Tue Jan 10 18:38:03 2012] [error] [client 46.206.115.253] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://tus-mureck.at/fotos/63-…93-img3467?tmpl=component [Tue Jan 10 18:38:03 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://www.tus-mureck.at/fotos…43-img6012?tmpl=component [Tue Jan 10 18:38:03 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://www.tus-mureck.at/fotos…43-img6012?tmpl=component [Tue Jan 10 18:38:05 2012] [error] [client 46.206.115.253] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://tus-mureck.at/fotos/63-…94-img3470?tmpl=component [Tue Jan 10 18:38:05 2012] [error] [client 46.206.115.253] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://tus-mureck.at/fotos/63-…94-img3470?tmpl=component [Tue Jan 10 18:38:06 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://www.tus-mureck.at/fotos…44-img6013?tmpl=component [Tue Jan 10 18:38:06 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://www.tus-mureck.at/fotos…44-img6013?tmpl=component [Tue Jan 10 18:38:08 2012] [error] [client 46.206.115.253] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://tus-mureck.at/fotos/63-…95-img3479?tmpl=component [Tue Jan 10 18:38:08 2012] [error] [client 46.206.115.253] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://tus-mureck.at/fotos/63-…95-img3479?tmpl=component [Tue Jan 10 18:38:08 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://www.tus-mureck.at/fotos…45-img6017?tmpl=component [Tue Jan 10 18:38:08 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://www.tus-mureck.at/fotos…45-img6017?tmpl=component [Tue Jan 10 18:38:10 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://www.tus-mureck.at/fotos…46-img6022?tmpl=component [Tue Jan 10 18:38:10 2012] [error] [client 178.191.200.104] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://www.tus-mureck.at/fotos…46-img6022?tmpl=component [Tue Jan 10 18:38:11 2012] [error] [client 46.206.115.253] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://tus-mureck.at/fotos/63-…96-img3484?tmpl=component [Tue Jan 10 18:38:11 2012] [error] [client 46.206.115.253] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://tus-mureck.at/fotos/63-…96-img3484?tmpl=component [Tue Jan 10 18:38:13 2012] [error] [client 46.206.115.253] File does not exist: /home/tusmuabf/www.tus-mureck.at/templates/system/css/template.css, referer: http://tus-mureck.at/fotos/63-…97-img3497?tmpl=component [Tue Jan 10 18:38:13 2012] [error] [client 46.206.115.253] File does not exist: /home/tusmuabf/www.tus-mureck.at/fotos, referer: http://tus-mureck.at/fotos/63-…97-img3497?tmpl=component


    jedoch gibt es diese Dateien - und es ist eine fotogallerie!! :D deshalb finde ich komisch, dass es hier einen Error gibt...



    Ach ja - gibts mittlerweile etwas bezüglich Ruby on Rails ??


    Danke,
    Patrick

    Toll --> Fehler gefunden...


    ich hatte letzte Woche das Kommentarzeichen beim "alten extension_dir" wieder gelöscht gehabt...


    das für die soap darüber aufgerufen und dann nicht mehr nach unten gesucht... ....... -.-


    Arrrrrggggg .........

    Hi!


    Ja das glaub ich dir... irgendwas hat es da jedenfalls!


    es funktioniert weder mit FastCGI noch mit cgiwrap - und die Umstellung der PHP-Versionen funktioniert auch nicht...
    kann man irgendwie die daten neu kompilieren?



    und nein - der extension_dir ist gesetzt in der PHP.ini aber die gibt immer ./ aus - was auch der Fehler anzeigt (dachte aber, dass dies der Pfad nach dem gesetzten ist!!)
    LG Patrick

    Hi,


    ja du sagst es: veraltet!


    Es gibt eine Fehlermeldung, dass DIESE soap.so für die Version 5.2.14 gültig ist, jedoch nicht für 5.2.17 !!!


    und genau das ist das Problem!
    Wir haben heute alle Möglichkeiten durchgetestet - aber das ist eben in der Fehlermeldung:


    Nach Absprache und Suche bedeutet: "Unknown on line 0" das die Versionen nicht zusammenpassen...


    PHP Startup: Unable to load dynamic library './soap.so' - ./soap.so: cannot open shared object file: No such file or directory in Unknown on line 0



    Es wäre ja auch kein Problem, wenn man in der pd-admin Serverkonfiguration auf PHP 5.2.14 umstellen könnte - funktioniert aber auch nicht... geht das manuell auch ?


    Danke Dir!

    Hi Leute,


    auf Grund des SOAP-Fehlers von gSales kamen wir im laufe des Tages auf folgendes:


    SOAP ist in version .14 vorhanden - die PHP version am Server (aktuellste Version ausgewählt) ist .17 ...


    Eine umstellung in der Serverkonfiguration auf PHP 5.2.14 funktioniert nicht!
    -->> somit kann SOAP nicht geladen werden!!


    kann man irgendwie PHP neu kompilieren (wie der Ordner schon zeigt wurde heute das letzte SE Update nochmals ausgeführt), damit man unter


    /usr/local/pd-admin2.2012-01-02T18\:35\:55/


    den Ordner php5-5.2.17/ mit den Dateien bekommt??


    alle anderen PHP Versionen sind vorhanden !!!


    ich hoffe diesnmal ist das Problem verständlich erklärt!!

    Also ich verwende die Version 2 und habe nur im Kundenfrontend das Problem mit SOAP. Verwende es aber nicht für PHP5.3 sondern für 5.2 ...


    und SOAP sollte ja bei der aktuellen Serverumgebung integriert sein!



    leider schaffe ich es nicht, dass soap auch geladen wird! in php.ini ist es eingetragen, jedoch wird angezeigt, dass die library nicht gefunden wird...


    //EDIT:


    hab es schon mit absolutem pfad probiert!


    kann es an 64bit, 32 bit liegen ???

    Hi,


    also das kann es dann wahrscheinlich nicht sein:


    Writing /usr/local/pd-admin2/conf/httpd.conf
    Syntax error on line 217 of /usr/local/pd-admin2/conf/httpd.conf:
    Invalid command 'zend_extension="/****/****/Zend/data/5_2_x_comp/ZendOptimizer.so"', perhaps misspelled or defined by a module not included in the server configuration


    vllt was ganz was anderes:
    die error log gibt aus, dass es anscheinend ein Problem mit 32 und 64 Bit gibt...


    Mein Debian ist 64bit - anscheinend ist aber die PHP-Umgebung (pd-admin) eine 32Bit umgebung....


    und siehe da: es läuft


    Somit braucht Zend nicht die Umgebung des Systems, sondern die, in der PHP kompiliert wurde...


    wie dann aber ein 32-bittiges PHP auf 64 bit Debian läuft.. naja.. :D keine Ahnung...

    Also erstmal danke für die Tipps!


    Hat jemand noch Rat für mich wegen Ruby on Rails ?


    zu ZendOptimizer:


    ich hab das Problem, dass ich nach 3 Stunden Fehlersuche nicht wirklich mehr eine Ahnung habe, was das Problem sein kann, dass ZendOptimizer nicht will...


    Info PHP gibt aus:


    PHP Version 5.2.17


    Zend Extension 220060519
    Zend Memory Manager enabled


    report_zend_debug On On
    zend.ze1_compatibility_mode Off Off


    This program makes use of the Zend Scripting Language Engine:
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies


    in /usr/local/pd-admin2/lib/php.ini wurde folgende Zeile am Anfang eingetragen:
    zend_extension="/****/****/Zend/data/5_2_x_comp/ZendOptimizer.so"


    und bei der gsales Seite kommt dann:


    Code
    Zend Optimizer not installed  This file was encoded by the Zend Guard. In order to run it, please install the Zend Optimizer (available without charge), version 3.0.0 or later. Seeing this message instead of the website you expected? This means that this webserver is not configured correctly. In order to view this website properly, please contact the website's system administrator/webmaster with the following message:  The component "Zend Optimizer" is not installed on the Web Server and therefore cannot service encoded files. Please download and install the Zend Optimizer (available without charge) on the Web Server.


    kann mir da jemand weiterhelfen?


    Dankeschön!

    - Welche Version von pd-admin wird eingesetzt?
    --aktuellste
    - Welche Version der Serverumgebung wird eingesetzt?
    --aktuellste



    Hi Leute,


    ich wollte mal ein paar allgemein Fragen loswerden, nachdem ich schon das Forum durchforstet habe, und sich schon einige sachen in anderen Beiträgen geklärt haben.. jedoch sind folgende auf grund von Kundenwünschen noch offen:


    --> Ruby on Rails: kann ich das ganz normal installieren, oder muss ich bei pd-admin etwas beachten?


    --> Zend Optimizer: ist dieser mittlerweile installiert, oder muss ich diesen wie bei anderen themen schon lang und breit erklärt erst nachinstallieren? Wenn ja: welche version soll ich verwenden: für PHP 5.2 oder PHP 5.3 ?? bzw. muss ich das für beide installieren, wenn anwendungen die 2er oder die 3er erfordern?


    --> Icinga: Hat schon jemand Icinga als Monitoring-Dienst installiert? Gibt es diesbezüglich irgendwelche Tipps für die Installation?


    --> gsales2: würde ich für PHP 5.2 installieren. Läuft das mittlerweile Problemlos unter pd-admin? (bezugnehmend: Probleme mit gsales)


    Ich wünsche Euch noch schöne Feiertage und würde mich über Hilfe freuen!


    Alles Liebe,
    Patrick

    Hi,


    ja das ist mir klar, dass Roundcube ein Webmailer ist - jedoch habe ich "gelesen", dass es anscheinend Plugins oder Ähnliches gibt, um die Spams im Roundcube direkt markieren zu lassen, dass es der besucher mitbekommt....


    jedoch vielen Dank für deinen Link zum Beitrag!!!!!


    LG Patrick

    Hi Leute,


    gibts dazu ein How-to im Forum? BZW: inwiefern ist das bei der aktuellen Version noch aktuell - oder lauft die Spamabwehr momentan gut mit Roundcube?


    Danke!


    Hi,


    hab bei den "großen" Portalen den Arbeitsspeicher auf 256 gesetzt - rest entweder 128 oder 64 - aber könntest recht haben - muss mal schauen was die "kleinen" so brauchen! :)


    Danke!!


    noch ne Frage kurz:


    Kriegt man diese Meldungen irgendwie weg?
    File does not exist: /usr/local/pd-admin2/htdocs/favicon.ico


    ich weiß nicht warum immer in diesen Verzeichnis gesucht wird.. auch nach PHP Dateien, etc...