Gravierender Fehler in libxml2.7.2

  • Hallo,


    ich betreue seit einiger Zeit einen PdAdmin Server für einen Freund und bin neu hier im Forum (gerade eben erst angemeldet).


    Seit dem Upgrade der Standard Serverumgebung von der Version 0.112 auf 0.117 gibt es Probleme mit der libxml2.


    Hier die genauen Informationen dazu:


    - Welche Version von pd-admin wird eingesetzt: v4.06
    - Welche Version der Serverumgebung wird eingesetzt: 2-0.117


    Die Version der libxml2 (libxml2.7.2) hat einen Bug im xml_parser. Das Problem besteht
    mit html_entities, kodierte Tag-Delimiter, also > und < werden ganz einfach gelöscht.


    Ein Beispiel findet sich hier:
    http://www.trancenation.it/libxml.php


    bzw. hier der Quelltext:


    Gibt dieser Code-Block folgendes zurück:


    a href=http://www.google.com>Google/a>


    Hier noch ein aktueller Bugreport auf der Typo3 Webseite:
    http://bugs.typo3.org/view.php?id=9514&nbn=8


    Aktuell gibts nur die Möglichkeit mit einem Downgrade der libxml2, wie kann
    man das aber in der SE machen, bzw. gibt es eine generelle Möglichkeit die gesamte
    SE ohne auftretenden Probleme auf eine ältere Version downzugraden?


    Das Problem ist wirklich schlimm und mein Freund ist täglich einer Reihe von Kundenreklamationen ausgesetzt :(


    Für eure Hilfe wäre ich euch sehr dankbar.


    Danke und Grüße
    Urban Lösch